Disclaimer

This is MY Viewer, i decide which feature i want to add and which to remove, i share this Viewer to show the world that user base size is not important, i do rate quality by effort, thought and love put into the project, not some rough estimated numbers. I consider feature requests only if i you can name proper valid reasons i can agree on. It is my unpaid time i'm putting into this project, i'm not here to cater to every Joe's desires.

Monday, December 12, 2016

Game Over Old Versions

You will not be missed.

Rest in pepperonis.

No seriously, you may have noticed (or not) that if you use a version prior to 2.5.6, the Viewer will automatically download (although not telling you, just indicating it via the slowly filling loading screen loading bar) the most recent version and force you to install that version (which you can of course close if you want but you wont be able to login with the old version anymore). So finally, after 4 years, all old versions will be done for, once and for all. This was not a one time thing, knowing that it works (and works even better than expected, the working install wasn't actually planned) means that in future i'll continue to block off older versions.

I told you all many times that at some point i'll do this if i ever get my hands on a working way to do it because it's really annoying dealing with old versions, not just for me but also for SL in general.



Well, f*ck you old versions.


I've also changed a few blog options. Most importantly i removed comment moderation, i used it to get a notification on comments because they are really easy to miss otherwise, instead i enabled sending emails whenever someone comments on any post. I'm sorry for all those comments i missed, Google changed the blogger main page several times and removed the "there are comments awaiting moderation" notification which is why i didn't see them. Things should be better now.

8 comments:

  1. Except the new version doesn't have RLV support yet, which is a complete dealbreaker. I use it too extensively to make up for LL being so bad at their jobs.

    I get wanting people to use the latest version but you've locked me out of the last version of BD I could use. Not cool.

    ReplyDelete
    Replies
    1. Well, you either have to use another Viewer then for the time being or you show some patience until Christmas.

      The last version you could use would be 2.5 Gamma. That version is outdated more than 5 months, i simply cannot let you or anyone else use it any further. It doesn't even contain full proper Bento support.

      You know best that using old versions is a nightmare for me and seeing everyone scattered all over the history of my Viewer is a massive disaster, i had to end it.


      So how about this:
      I'll drop everything right now and get on RLVa right away and push the update as soon as its ready? At the cost of having no Christmas gift.

      Delete
    2. The latest version will not work for me at all. It opens, loads, but as soon as the world loads it either freezes and I get logged out, or I am stuck in the 'taking a poo' pose and cant move or interact with anything. It WAS working perfectly, until the new version was forced on me. The one I cannot use at all. So, yeah, thanks. Either fix whatever was borked in this update, or let us use versions that actually work.

      Delete
    3. Pretty late to the party i suppose... but anyway.

      It would be helpful to have some information on what is actually going on.

      What was your last version you used, how old was it?
      I could possibly think of a case in which you used one of the versions with the old control binding files that may be interfering here.

      I need the log file to take a look into what's happening, if anything is actually happening on the Viewer end.

      Also, have you checked if its not your Router?

      Have you checked your settings, did you reset your settings?

      Have you tried clearing cache?

      Updating from very old versions can cause problems if you don't clear settings and/or cache. You might want to try that.

      Also make sure your Firewall or AntiVirus application (if you got one) aren't blocking any connections.

      Delete
    4. I'm not sure exactly on the version of the previous working install. The Installer I have in my downloads folder is 2.5g. I have no idea where to acquire the log file, or I would send it. I did try setting graphics to the lowest possible settings, no I did not try resetting the settings. After the 4th attempt to log in, and not being able to do anything, I kind of gave up. No I did not clear cache, as normally it is not advised to do that to try to fix viewer problems. Yes, I made sure there is an exception for BD in my firewall and antivirus. And, lastly, no it is not my router, as I had no trouble at all logging in on Firestorm Viewer.

      Delete
    5. Just marking this problem as solved:
      Issue was most likely fast cache or old controls file causing movement or login issues.
      Fix was simply clearing settings.

      Delete
  2. I understand the necessary blocking of older viewers, (something that firestorm and other viewers do already)and i appreciate everything you have done on this viewer. I am liking it so far.

    The only think I'm experiencing on your newest viewer is, when i sit on an object, the standup button no longer works. i click right threw it.
    https://gyazo.com/07bdead58fd3b55f7e83622482c8079b
    I can still right click and hit unsit in the dropdown though.

    ReplyDelete
    Replies
    1. Was reported already and a fix has been made. It will be in the next update.

      Delete